Меню
Тесты
Тесты  /  Информатика  /  9 класс  /  Тест "Массивы в Паскале"

Тест "Массивы в Паскале"

Avatar
21.04.2020. Тест. Информатика, 9 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест предназначен для проверки знаний обучающихся, изучающих язык программирования Паскаль, по теме "Массивы"

Список вопросов теста

Вопрос 1

Для заполнения массива путем ввода чисел с клавиатуры мы используем оператор…

Варианты ответов
  • Write
  • Repeat
  • Until
  • Readln
Вопрос 2

Найдите правильное описание массива.

Варианты ответов
  • D[1..5]:array of integer;
  • D: array[1..5] of real;
  • D: array[1...5] of real;
  • Array D: [1..5] of real
Вопрос 3

Массив R[1]=12, R[2]=3, R[3]=-5, R[4]=-6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.
Определите значение переменной sum после выполнения следующего фрагмента программы:
sum:=0;
N:=3;
for i:=1 to N do
if r[i]>5 then
sum:=sum+r[i];

Вопрос 4

Для подсчета суммы элементов массива А в цикле используем следующую запись…

Варианты ответов
  • Sum:=sum+А(i);
  • Sum:=sum+i;
  • Sum:=А[i]+sum;
  • Sum:=А[i]+А[i+1];
Вопрос 5

Массив R[1]=12, R[2]=3, R[3]=-5, R[4]=-6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.
Определите значение sum после выполнения следующего фрагмента программы:
sum:=1;
for i:=1 to 7 do
if r[i]>5 then
sum:=sum+r[i];

Вопрос 6

Как задается количество элементов  массива?

Варианты ответов
  • Номером и значением первого элемента
  • Номером последнего элемента
  • Значением первого и последнего элемента
  • Индексом первого и последнего элемента
Вопрос 7

Индексом элемента называется ...

Варианты ответов
  • номер элемента в массиве
  • номер первого и последнего элемента массива
  • последний элемент в массиве
  • значение элемента массива
Вопрос 8

Массив данных имеет

Варианты ответов
  • общее имя и один тип
  • общее имя, один тип, разные значения
  • один тип и разные значения
  • один тип
Вопрос 9

Что выполняет следующий фрагмент программы:

For i:=1 to N do
write (a[ i ], ‘ ’);

Варианты ответов
  • выводит N значений массива на экран в столбик
  • производит ввод N элементов в массив
  • выводит N значений массива на экран в строчку
  • выполняет проверку значений элементов массива
Вопрос 10

Массив R[1]=12, R[2]=3, R[3]=-5, R[4]=-6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.
Определите значение переменной kol после выполнения следующего фрагмента программы:
kol:=0;
for i:=4 to 8 do
if r[i]<0 then
kol:=kol+1;

Вопрос 11

Массив R[1]=12, R[2]=3, R[3]=-5, R[4]=-6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.
Определите значение переменной kol после выполнения следующего фрагмента программы:
kol:=0;
for i:=1 to 8 do
if r[i]>-2 then
kol:=kol+1

Вопрос 12

Массив R[1]=12, R[2]=3, R[3]=5, R[4]=6, R[5]=4, R[6]=9, R[7]=12, R[8]=8.
Определите значение переменной min после выполнения следующего фрагмента программы: 

min:=0
for i:=1 to 8 do
if r[i]<min then
min:=r[i];

Вопрос 13

Массив R[1]=12, R[2]=3, R[3]=-5, R[4]=-6, R[5]=4, R[6]=9, R[7]=0, R[8]=8.
Определите значение переменной k после выполнения следующего фрагмента программы:
k:=0;
for i:=1 to 8 do
if r[i]>5 then
k:=k+i;

Вопрос 14

В записи D[4]=2.5,
2.5 обозначает

Варианты ответов
  • имя массива
  • обозначение типа
  • значение элемента массива
  • имя ячейки
Вопрос 15

Что выполняет следующий фрагмент программы?
Min:=a[1];
For i:=1 to N do
if a[i]< min then
min:=a[i];
Writeln(min);

Варианты ответов
  • находит значение минимального элемента массива
  • сравнивает первый элемент массива с минимальным элементом
  • находит индекс минимального элемента массива
  • делает значения элементов массива минимальными
Вопрос 16

В какой строке НЕ правильное описание массива?

Варианты ответов
  • var ch: array[1..10] of integer
  • var stih: array[1,5..7] of real
  • var STL23: array[2..108] of real
Вопрос 17

Какое количество данных может находиться в данном массиве

 var ch: array[3..15] of integer;?

Варианты ответов
  • 13 целых чисел
  • 12 целых чисел;
  • 13 букв
  • 12 дробных чисел.
Вопрос 18

Каким способом осуществляется ввод элементов массива

  randomize;

  writeln('Введите количество элементов массива');

  readln(n);

  for i:=1 to n do

  begin  a[i]:=random(50);  writeln('a['i']=)',a[i]);   end;

Варианты ответов
  • с помощью датчика случайных чисел
  • с клавиатуры
  • присвоением заданных значений
Вопрос 19

Каким способом осуществляется ввод элементов массива

  writeln('Введите количество элементов массива');

  readln(n);

  for i:=1 to n do

  begin   a[i]:=i*i/i+2;  writeln('a(',i,')=',a[i]);  end;

Варианты ответов
  • с помощью датчика случайных чисел
  • с клавиатуры
  • присвоением заданных значений
Вопрос 20

Числовой одномерный массив А заполнен последовательно числами 4, 8, 13, 25. Укажите значение элемента А[3].

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт