Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Начало программирования. Python

Начало программирования. Python

Avatar
18.05.2022. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Начало программирования. Python. Тест по терминам языка Python

Список вопросов теста

Вопрос 1

Разработчиком языка Python является: 

Варианты ответов
  • Блез Паскаль
  • Никлаус Вирт
  • Гвидо ван Россум
  • Норберт Винер
Вопрос 2

Что из нижеперечисленного входит в алфавит языка Python?

Варианты ответов
  • латинские строчные и прописные буквы
  • служебные слова
  • русские строчные и прописные буквы
  • знак подчёркивания
Вопрос 3

Какая последовательность символов может служить именем в языке Python?

Варианты ответов
  • _k1
  • s25
  • 2as
  • and
Вопрос 4

Вещественные числа имеют тип данных:

Варианты ответов
  • int
  • bool
  • float
  • str
Вопрос 5

Языковые конструкции, с помощью которых в программах записываются действия, выполняемые в процессе решения задачи, называются:

Варианты ответов
  • данными
  • выражениями
  • операторами
  • операндами
Вопрос 6

Что будет в результате выполнения следующего действия print(23 % 2)

 

Варианты ответов
  • 1
  • 11
Вопрос 7

Переменная int:

Варианты ответов
  • вещественная переменная
  • символьная строка
  • логическая переменная
  • целая переменная
Вопрос 8

Строковый тип данных обозначается:

Варианты ответов
  • int
  • bool
  • float
  • str
Вопрос 9

Что будет в результате выполнения следующего алгоритма программы: 

Входные данные: 

а=15

b=45

a = int(input())
b = int(input())
if a % 10 == 0 or b % 10 == 0:
    print('YES')
else:
    print('NO')

Варианты ответов
  • YES
  • NO
Вопрос 10

Какие существуют типы переменных  в Python (выбрать несколько выриантов):

Варианты ответов
  • float
  • str
  • bool
  • int
  • real
  • num
Вопрос 11

Результатом вычисления print(23 // 3) будет число:

Варианты ответов
  • 2
  • 7
Вопрос 12

Что будет в результате следующего действия print(2**3)

Варианты ответов
  • 6
  • 8
Вопрос 13

Что будет в результате выполнения программы:

a = 20

b = a + 4

a = b * 100

print(a)

В качестве ответа введите число

Вопрос 14

При присваивании изменяется:

Варианты ответов
  • имя переменной
  • тип переменной
  • значение переменной
  • значение константы
Вопрос 15

Какие операторы цикла существуют в языке Python?

Варианты ответов
  • for
  • while
  • repeat... until
Вопрос 16

Определите значение переменной с после выполнения следующего фрагмента программы: 

а = 100 

b= 30

а = а - b * 3

if а > b:

   с = а - b

else:

   с = b - а

Варианты ответов
  • 20
  • 70
  • -20
  • 180
Вопрос 17

Для вывода результатов в Python используется оператор:

Варианты ответов
  • while
  • input ()
  • print ()
  • and
Вопрос 18

Для ввода результатов в Python используется оператор:

Варианты ответов
  • while
  • input ()
  • print ()
  • and
Вопрос 19

Тело цикла в фрагменте программы

а = 1

b = 1

while а + Ь < 8:

а +=1

b+= 2

выполнится:

Варианты ответов
  • 2 раза
  • 3 раза
  • 4 раза
Вопрос 20

Для чего нужен оператор break?

Варианты ответов
  • для завершения программы
  • для выхода из цикла
  • для удаления программы
Вопрос 21

При записи на языке Python разветвляющихся алгоритмов используют условный оператор. Укажите его общий вид

Варианты ответов
  • if – elif – else
  • if – else
  • if
Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт