Меню
Тесты
Тесты  /  Информатика  /  Прочее  /  Python. Циклы с предусловием. Вариант 2

Python. Циклы с предусловием. Вариант 2

Avatar
18.03.2024. Тест. Информатика, Прочее
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Пройди тест до конца, чтобы получить оценку. Внимательно читай вопросы.

Список вопросов теста

Вопрос 1

Цикл с предусловием – это цикл, который:

Варианты ответов
  • Повторяется определенное число раз
  • Повторяется до тех пор, пока условие верное
  • Повторяется до тех пор, пока условие ложное
Вопрос 2

Чему будет равно значение переменной «a» после выполнения этого цикла?

  i = 4
  a = 12
  while i < 5:
    a += i
    i += 1
Вопрос 3

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

  i = ...
  while i <= 2:
    print ( "Привет!" )
    i += 1
Вопрос 4

Сколько раз будет выполнен этот цикл?

  i = 3
  while i < 7:
    print ( "Привет!" )
    i += 1
Вопрос 5

Какое число нужно написать вместо многоточия, чтобы цикл выполнился ровно 2 раза?

  i = 3
  while i >= ...:
    print ( "Привет!" )
    i -= 1
Вопрос 6

Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:

a=1

b=1
while a>=b: 

     b=b+a 

     a=a+1

print(b*a)

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт