Меню
Тесты
Тесты  /  Информатика  /  8 класс  /  Циклический оператор в Python

Циклический оператор в Python

Avatar
22.10.2023. Тест. Информатика, 8 класс
Внимание! Все тесты в этом разделе разработаны пользователями сайта для собственного использования. Администрация сайта не проверяет возможные ошибки, которые могут встретиться в тестах.
Тест по языку программирования Python для учеников 8 класса по теме "Циклический оператор". В тесте есть две задачи, которые проверит учитель.

Список вопросов теста

Вопрос 1

Определите значение переменной f  после выполнения фрагмента алгоритма.
f = 0
fоr i in rаngе (1, 6):
     f = f + i
print (f)

Вопрос 2

Определите значение переменной k после выполнения фрагмента алгоритма.
 к = o
for i in rаngе (1, 6)
    if i % 2 == 0:
          к = к + i 
print (k)

Варианты ответов
  • 6
  • 15
  • 12
Вопрос 3

S = 0
for  i in range (2, 31):
     if  i % 3 == 0: 
         S = S + i
print (S)

Варианты ответов
  • нахождение суммы чисел от 2 до 30;
  • нахождения суммы чисел кратных 3 в интервале от 2 до 30
  • вывод на экран чисел кратных 3;
  • нахождения суммы нечетных чисел в интервале от 2 до 30;
Вопрос 4

S = 0
for i in range(2,7,2): 
    S +=i
    print("S= ", S)

Варианты ответов
  • 12
  • 7
  • 5
  • 10
Вопрос 5

Какая ошибка допущена в следующей программе?

for i in range(1,-6,1): 
    S +=i
    print("S= ", S)

Варианты ответов
  • бесконечный цикл
  • неправильное условие окончания цикла
  • в программе нет ошибок
  • неправильное указание числа повторений цикла
Вопрос 6

Что такое цикл?

Варианты ответов
  • Вид ошибки
  • Условие повторения совокупности операторов
  • Этапы решения задач на компьютере
Вопрос 7

Напишите программу для нахождения количества двузначных чисел, кратных 5.

Вопрос 8

Напишите программу для  определения суммы  чётных чисел на промежутке [44;120]

Пройти тест
Сохранить у себя:

Комментарии 0

Чтобы добавить комментарий зарегистрируйтесь или на сайт